Prepare master for new framework integration
[AGL/meta-agl-demo.git] / recipes-platform / packagegroups / packagegroup-agl-demo-platform-html5.bb
index 9092b18..d0c81c6 100644 (file)
@@ -5,22 +5,33 @@ LICENSE = "MIT"
 
 inherit packagegroup
 
+PROVIDES = "${PACKAGES}"
 PACKAGES = "\
     packagegroup-agl-demo-platform-html5 \
+    packagegroup-agl-demo-platform-html5-devel \
     "
 
-ALLOW_EMPTY_${PN} = "1"
+ALLOW_EMPTY:${PN} = "1"
 
-RDEPENDS_${PN} += "\
+RDEPENDS:${PN} += "\
     packagegroup-agl-image-ivi \
     "
 
-# add packages for demo platform (include demo apps) here
-RDEPENDS_${PN} += " \
-    packagegroup-agl-demo \
+RDEPENDS:${PN} += "\
+    packagegroup-hmi-framework \
     "
 
-# add packages for OpenIVI-HTML5 demo
-RDEPENDS_${PN} += " \
-    openivi-html5 \
+
+RDEPENDS:${PN}:append = " \
+    weston-ini-conf \
+    ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'unzip' , '', d)} \
+    "
+
+# NOTE: Currently no coverage versions for the application widgets,
+#       they should be added here when available.
+#       Also, the navigation and mixer debug widgets are currently
+#       specified explicitly, as there's no simple way to derive their
+#       names from the virtual/ RPROVIDES at present.
+RDEPENDS:${PN}-devel = " \
+    packagegroup-hmi-framework-devel \
     "