Add CAN test tools image feature
[AGL/meta-agl-demo.git] / recipes-platform / images / agl-kvm-demo-platform.bb
index d04186b..feafe2e 100644 (file)
@@ -2,13 +2,20 @@ DESCRIPTION = "AGL KVM+QEMU Demo Platform image."
 
 LICENSE = "MIT"
 
-require recipes-platform/images/agl-image-weston.inc
+require recipes-platform/images/agl-image-compositor.bb
+require agl-demo-features.inc
 
 IMAGE_FEATURES += "splash package-management ssh-server-openssh"
 
+# If building with "agl-kvm-host-kuksa", the databroker and likely
+# some clients run on the host
+IMAGE_FEATURES += " \
+    ${@bb.utils.contains("AGL_FEATURES", "agl-kvm-host-kuksa", "kuksa-val-databroker kuksa-val-databroker-client", "", d)} \
+    ${@bb.utils.contains("DISTRO_FEATURES", "agl-devel", "can-test-tools" , "", d)} \
+"
+
 # Add packages for KVM+QEMU demo platform here
-IMAGE_INSTALL:append = " \
-    packagegroup-agl-image-minimal \
+IMAGE_INSTALL += " \
     packagegroup-agl-core-connectivity \
     kernel-image \
     agl-compositor \
@@ -36,9 +43,6 @@ GUEST_IMAGES ?= "agl-kvm-guest:${GUEST_VM1_IMAGE} agl-kvm-guest:${GUEST_VM2_IMAG
 
 QEMU_GUEST_CONFIGS ?= ""
 
-# Handle modification of IMAGE_LINK_NAME done by ULCB builds with Kingfisher support
-MACHINE_SUFFIX = "${@bb.utils.contains('AGL_FEATURES', 'kingfisher', '-kf', '', d)}"
-
 python __anonymous() {
     for c in (d.getVar('GUEST_IMAGES') or "").split():
         (mc, image) = c.split(':')
@@ -56,7 +60,7 @@ install_guest_images() {
         name=${image}
         rm -rf  ${IMAGE_ROOTFS}/var/lib/machines/${name}
         install -m 0755 -d ${IMAGE_ROOTFS}/var/lib/machines/${name}
-        src="${TOPDIR}/tmp-${config}/deploy/images/${GUEST_MACHINE}/${image}-${GUEST_MACHINE}${MACHINE_SUFFIX}.ext4"
+        src="${TOPDIR}/tmp-${config}/deploy/images/${GUEST_MACHINE}/${image}-${GUEST_MACHINE}.ext4"
         bbnote "Installing ${src}"
         install -m 0600 ${src} ${IMAGE_ROOTFS}/var/lib/machines/${name}/
        # Placeholder until booting from kernel in VM image is worked out