agl-ivi-demo-platform-crosssdk: Add grpc-dev for crossdk
[AGL/meta-agl-demo.git] / recipes-platform / images / agl-ivi-demo-platform-crosssdk.bb
index 45db0e3..c5f5d1d 100644 (file)
@@ -1,19 +1,11 @@
+require agl-ivi-demo-platform.bb
+
 SUMMARY = "Cross SDK of Full AGL Distribution for IVI profile"
 
 DESCRIPTION = "SDK image for full AGL Distribution for IVI profile. \
 It includes the full meta-toolchain, plus developement headers and libraries \
 to form a standalone cross SDK."
 
-
-require agl-image-ivi.bb
-
-# add packages for demo platform (include demo apps) here
-IMAGE_INSTALL:append = " \
-    packagegroup-agl-demo-platform \
-    "
-
-LICENSE = "MIT"
-
 require recipes-platform/images/agl-image-minimal-crosssdk.inc
 
 # Add wayland-scanner to SDK (SPEC-945)
@@ -27,7 +19,8 @@ TOOLCHAIN_HOST_TASK:append = " nativesdk-perl-modules "
 # Add qtwaylandscanner to the SDK
 TOOLCHAIN_HOST_TASK:append = " nativesdk-qtwayland-tools "
 
-
+# add grpc for building natively for grpc_cpp_plugin
+TOOLCHAIN_HOST_TASK:append = " nativesdk-grpc nativesdk-grpc-dev "
 # Task do_populate_sdk and do_rootfs can't be exec simultaneously.
 # Both exec "createrepo" on the same directory, and so one of them
 # can failed (randomly).
@@ -50,10 +43,10 @@ TOOLCHAIN_TARGET_TASK += "waltham-dev"
 
 TOOLCHAIN_HOST_TASK += " \
     nativesdk-lua \
-    "
+"
 
 # Required dependencies for app and test builds
 TOOLCHAIN_TARGET_TASK += " \
     lua-dev \
     lua-staticdev \
-    "
+"