Prepare master for new framework integration
[AGL/meta-agl-demo.git] / recipes-platform / images / agl-ivi-demo-platform-crosssdk.bb
diff --git a/recipes-platform/images/agl-ivi-demo-platform-crosssdk.bb b/recipes-platform/images/agl-ivi-demo-platform-crosssdk.bb
new file mode 100644 (file)
index 0000000..4900476
--- /dev/null
@@ -0,0 +1,59 @@
+SUMMARY = "Cross SDK of Full AGL Distribution for IVI profile"
+
+DESCRIPTION = "SDK image for full AGL Distribution for IVI profile. \
+It includes the full meta-toolchain, plus developement headers and libraries \
+to form a standalone cross SDK."
+
+
+# add packages for demo platform (include demo apps) here
+IMAGE_INSTALL:append = " \
+    packagegroup-agl-demo-platform \
+    "
+
+LICENSE = "MIT"
+
+#require agl-image-graphical-qt5-crosssdk.inc
+require recipes-platform/images/agl-image-weston.inc
+require recipes-platform/images/agl-image-minimal-crosssdk.inc
+
+# Add wayland-scanner to SDK (SPEC-945)
+# Use TOOLCHAIN_HOST_TASK instead of adding to the packagegroup
+# wayland-scanner is in nativesdk-wayland-dev !
+# option: add also nativesdk-qtwayland-tools
+TOOLCHAIN_HOST_TASK:append = " nativesdk-wayland nativesdk-wayland-dev"
+
+TOOLCHAIN_HOST_TASK:append = " nativesdk-perl-modules "
+
+# Add qtwaylandscanner to the SDK
+TOOLCHAIN_HOST_TASK:append = " nativesdk-qtwayland-tools "
+
+
+# Task do_populate_sdk and do_rootfs can't be exec simultaneously.
+# Both exec "createrepo" on the same directory, and so one of them
+# can failed (randomly).
+addtask do_populate_sdk after do_rootfs
+
+inherit populate_sdk populate_sdk_qt5
+
+# Task do_populate_sdk and do_rootfs can't be exec simultaneously.
+# Both exec "createrepo" on the same directory, and so one of them
+# can failed (randomly).
+addtask do_populate_sdk after do_rootfs
+
+# Add gcc-sanitizers to support building applications using the SDK with
+# AddressSanitizer support to detect use-after-frees along with other
+# memory issue.
+TOOLCHAIN_TARGET_TASK += "gcc-sanitizers"
+
+TOOLCHAIN_TARGET_TASK += "waltham-dev"
+
+
+TOOLCHAIN_HOST_TASK += " \
+    nativesdk-lua \
+    "
+
+# Required dependencies for app and test builds
+TOOLCHAIN_TARGET_TASK += " \
+    lua-dev \
+    lua-staticdev \
+    "
\ No newline at end of file