GATEWAY-EW24
[AGL/meta-agl-demo.git] / recipes-platform / images / agl-ivi-demo-control-panel.bb
index 21785ca..c9bd890 100644 (file)
@@ -1,9 +1,19 @@
 require recipes-platform/images/agl-image-weston.bb
+require agl-demo-features.inc
 
 SUMMARY = "AGL demo control panel image"
 
 IMAGE_FEATURES += "splash package-management ssh-server-openssh"
 
+# KUKSA.val databroker is only installed with
+# "agl-demo-gateway-preload" feature, as it used as
+# a bridge to CAN output via kuksa-dbc-feeder in that
+# configuration.
+IMAGE_FEATURES += " \
+    kuksa-val-databroker-client \
+    ${@bb.utils.contains("AGL_FEATURES", "agl-demo-gateway-preload", "kuksa-val-databroker", "", d)} \
+"
+
 # NOTE: The client key and certificate in kuksa-certificates-agl-client
 #       seem required by kuksa-client at the moment even though client
 #       certification has been deprecated upstream, this needs further
@@ -24,4 +34,5 @@ IMAGE_INSTALL += "\
     qtwayland \
     qtwayland-plugins \
     qtwayland-qmlplugins \
+    ${@bb.utils.contains("DISTRO_FEATURES", "agl-devel", "can-test-tools" , "", d)} \
 "