Add packages to agl-demo-platform for CES2017 Demo
[AGL/meta-agl-demo.git] / recipes-platform / images / agl-demo-platform.bb
index c58d22c..a387879 100644 (file)
@@ -24,6 +24,41 @@ IMAGE_TTF_FONTS = " \
     "
 
 # add packages for CES2017 demo
+# Only for porter as these kernel module sources
+# are for the 3.10.x kernel only
+MOST_DRIVERS = " "
+MOST_DRIVERS_append_porter = " \
+    aim-cdev \
+    aim-network \
+    aim-sound \
+    aim-v4l2 \
+    hdm-dim2 \
+    hdm-i2c \
+    hdm-usb \
+    mocca-usb \
+    mostcore \
+    "
+
+# HVAC dependencies depend on drivers above
+IMAGE_MOST_HVAC = " "
+IMAGE_MOST_HVAC_append_porter = " \
+    ${MOST_DRIVERS} \
+    unicens \
+    vod-server \
+    "
+
+# can-lin is a binary and only for porter :(
+IMAGE_MOST_HVAC_append_porter = " \
+    can-lin \
+    "
+
+IMAGE_AGL_APPS = " \
+    hvac \
+    mediaplayer \
+    navigation \
+    settings \
+    "
+
 IMAGE_INSTALL_append = " \
     ces2017-demo \
     linux-firmware-ath9k \
@@ -35,5 +70,7 @@ IMAGE_INSTALL_append = " \
     climatecontrolplugin \
     navigation \
     poiapp \
+    ${IMAGE_MOST_HVAC} \
+    ${IMAGE_AGL_APPS} \
     ${IMAGE_TTF_FONTS} \
     "