Suspend addition of libavirt-staticdev in SDK
[AGL/meta-agl-demo.git] / recipes-platform / images / agl-demo-platform-crosssdk.bb
index 65de7fe..f205fdb 100755 (executable)
@@ -44,9 +44,16 @@ TOOLCHAIN_TARGET_TASK += " \
     libssp-dev \
     lua-dev \
     lua-staticdev \
+    libafb-helpers-staticdev \
+    libafb-helpers-qt-staticdev \
+    libappcontroller-staticdev \
     ${@bb.utils.contains('LICENSE_FLAGS_WHITELIST', 'commercial', 'ffmpeg-dev', '', d)} \
     "
 
+#    ${@bb.utils.contains('DISTRO_FEATURES', 'agl-audio-4a-framework', 'libavirt-staticdev' , '', d)} \
+#
+
+
 # Add wayland-scanner to SDK (SPEC-945)
 # Use TOOLCHAIN_HOST_TASK instead of adding to the packagegroup
 # wayland-scanner is in nativesdk-wayland-dev !
@@ -60,3 +67,10 @@ TOOLCHAIN_TARGET_TASK += " \
     libvcard-dev \
     libvcard-staticdev \
     "
+
+# Add mosquitto to support building the telematics demo application.
+# This is currently required for CI, as it uses agl-demo-platform-crosssdk
+# to build everything. An agenda item has been tabled for the May 2019 F2F
+# meeting to discuss the path forward (separate versus superset SDKs), this
+# should be reviewed after that.
+TOOLCHAIN_TARGET_TASK += "mosquitto-dev"