SPEC-3723: add appfw dependencies back to SDK image
[AGL/meta-agl-demo.git] / recipes-platform / images / agl-demo-platform-crosssdk.bb
index ff3e9df..7f98b41 100644 (file)
@@ -8,7 +8,7 @@ require agl-demo-platform.bb
 
 LICENSE = "MIT"
 
-require recipes-platform/images/agl-image-graphical-qt5-crosssdk.inc
+require agl-image-graphical-qt5-crosssdk.inc
 
 inherit populate_sdk populate_sdk_qt5
 
@@ -54,3 +54,17 @@ TOOLCHAIN_TARGET_TASK += "aws-iot-device-sdk-embedded-c-staticdev"
 TOOLCHAIN_TARGET_TASK += "aws-iot-device-sdk-embedded-c-dev"
 
 TOOLCHAIN_TARGET_TASK += "waltham-dev"
+
+
+# Required dependencies for app and test builds
+TOOLCHAIN_HOST_TASK += " \
+    nativesdk-lua \
+    "
+
+# Required dependencies for app and test builds
+TOOLCHAIN_TARGET_TASK += " \
+    lua-dev \
+    lua-staticdev \
+    libafb-helpers-staticdev \
+    libappcontroller-staticdev \
+    "
\ No newline at end of file