SPEC-3723: add appfw dependencies back to SDK image
[AGL/meta-agl-demo.git] / recipes-platform / images / agl-demo-platform-crosssdk.bb
index d71eb88..7f98b41 100644 (file)
@@ -8,7 +8,7 @@ require agl-demo-platform.bb
 
 LICENSE = "MIT"
 
-require recipes-platform/images/agl-image-graphical-qt5-crosssdk.inc
+require agl-image-graphical-qt5-crosssdk.inc
 
 inherit populate_sdk populate_sdk_qt5
 
@@ -44,9 +44,27 @@ TOOLCHAIN_TARGET_TASK += "gcc-sanitizers"
 # and other users of Azure sdk.
 TOOLCHAIN_TARGET_TASK += "azure-iot-sdk-c umock-c"
 
+# Add mbedTLS to support building aws-iot-device-sdk-embedded-c
+TOOLCHAIN_TARGET_TASK += "mbedtls"
+
 # Add aws-iot-device-embedded-c sdk to support building agl-service-cloudproxy
 # and other users of AWS sdk.
 # These packages are required to add static library and headers:
 TOOLCHAIN_TARGET_TASK += "aws-iot-device-sdk-embedded-c-staticdev"
 TOOLCHAIN_TARGET_TASK += "aws-iot-device-sdk-embedded-c-dev"
 
+TOOLCHAIN_TARGET_TASK += "waltham-dev"
+
+
+# Required dependencies for app and test builds
+TOOLCHAIN_HOST_TASK += " \
+    nativesdk-lua \
+    "
+
+# Required dependencies for app and test builds
+TOOLCHAIN_TARGET_TASK += " \
+    lua-dev \
+    lua-staticdev \
+    libafb-helpers-staticdev \
+    libappcontroller-staticdev \
+    "
\ No newline at end of file