SDK: add native+target packages to build chromium
[AGL/meta-agl-demo.git] / recipes-platform / images / agl-demo-platform-crosssdk.bb
index 9765015..6df9521 100644 (file)
@@ -6,8 +6,10 @@ to form a standalone cross SDK."
 
 require agl-demo-platform.bb
 
-IMAGE_FEATURES_append = "dev-pkgs"
-IMAGE_INSTALL_append = "kernel-dev"
+LICENSE = "MIT"
+
+IMAGE_FEATURES_append = " dev-pkgs"
+IMAGE_INSTALL_append = " kernel-dev kernel-devsrc"
 
 inherit populate_sdk populate_sdk_qt5
 
@@ -15,3 +17,30 @@ inherit populate_sdk populate_sdk_qt5
 # Both exec "createrepo" on the same directory, and so one of them
 # can failed (randomly).
 addtask do_populate_sdk after do_rootfs
+
+# native tools to support Chromium build inside SDK (SPEC-942)
+TOOLCHAIN_HOST_TASK += " \
+    nativesdk-gn \
+    nativesdk-ninja \
+    nativesdk-gperf \
+    nativesdk-zlib \
+    nativesdk-xz \
+    nativesdk-nspr-dev \
+    nativesdk-nss-dev \
+    "
+
+# required dependencies for Chromium build inside SDK (SPEC-942)
+TOOLCHAIN_TARGET_TASK += " \
+    pciutils-dev \
+    pulseaudio-dev \
+    cairo-dev \
+    nss-dev \
+    cups-dev \
+    gconf-dev \
+    libexif-dev \
+    pango-dev \
+    libdrm-dev  \
+    libssp-dev \
+    ffmpeg-dev \
+    "
+