Remove systemd user session and clean up packagegroups and images
[AGL/meta-agl-demo.git] / recipes-platform / images / agl-cluster-demo-platform-flutter.bb
index 735bb31..fc3cc51 100644 (file)
@@ -2,7 +2,7 @@ SUMMARY = "Baseline Flutter Image for Release"
 
 LICENSE = "MIT"
 
-require recipes-platform/images/agl-image-weston.inc
+require recipes-platform/images/agl-image-compositor.bb
 
 IMAGE_FEATURES += "splash package-management ssh-server-openssh"
 
@@ -11,19 +11,19 @@ IMAGE_FEATURES += "splash package-management ssh-server-openssh"
 # running the full stack locally.
 IMAGE_KUKSA_PACKAGES = " \
     kuksa-val \
+    kuksa-databroker \
     kuksa-val-agl \
+    kuksa-databroker-agl \
     kuksa-certificates-agl \
     kuksa-dbc-feeder \
     kuksa-vss-init \
+    ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'kuksa-databroker-cli' , '', d)} \
 "
 
 # generic
-IMAGE_INSTALL:append = "\
-    agl-compositor \
-    agl-compositor-init \
+IMAGE_INSTALL += "\
     ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "weston-ini-conf-landscape-inverted", "weston-ini-conf-landscape", d)} \
     \
-    packagegroup-agl-profile-graphical \
     packagegroup-agl-networking \
     cluster-receiver \
     \
@@ -32,11 +32,11 @@ IMAGE_INSTALL:append = "\
     "
 
 # Flutter
-IMAGE_INSTALL:append = "\
+IMAGE_INSTALL += "\
     flutter-cluster-dashboard \
-    ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "cluster-demo-config-flutter", "", d)} \
     ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "flutter-cluster-dashboard-conf-demo", "flutter-cluster-dashboard-conf", d)} \
-    flutter-auto-runtimerelease \
+    cluster-demo-config-flutter \
+    flutter-auto \
     "
 
 CLANGSDK = "1"