Add KUKSA.val databroker image features
[AGL/meta-agl-demo.git] / recipes-platform / images / agl-cluster-demo-platform-flutter.bb
index 40aa6e8..5cf3daf 100644 (file)
@@ -2,24 +2,36 @@ SUMMARY = "Baseline Flutter Image for Release"
 
 LICENSE = "MIT"
 
+require recipes-platform/images/agl-image-compositor.bb
+require agl-demo-features.inc
 
-require recipes-platform/images/agl-image-weston.inc
+IMAGE_FEATURES += "splash package-management ssh-server-openssh"
 
-# generic
-IMAGE_INSTALL:append = "\
-    agl-compositor \
-    agl-compositor-init \
-    packagegroup-agl-profile-graphical \
-    packagegroup-agl-ivi-services \
-    "
+# KUKSA.val databroker is not installed with "agl-demo-preload"
+# feature enabled, since demo unit configuration points at the
+# databroker on the IVI board in that setup.
+IMAGE_FEATURES += " \
+    kuksa-val-databroker-client \
+    ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "", "kuksa-val-databroker", d)} \
+"
 
-# flutter
-IMAGE_INSTALL:append = "\
-    weston-ini-conf-landscape \
+# Generic
+IMAGE_INSTALL += "\
+    ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "psplash-inverted-config", "", d)} \
+    ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "weston-ini-conf-landscape-inverted", "weston-ini-conf-landscape", d)} \
+    \
+    packagegroup-agl-networking \
+    cluster-receiver \
     \
-    flutter-cluster-dashboard-runtimerelease \
-    flutter-cluster-dashboard-runtimerelease-init \
-    flutter-auto-runtimerelease \
+    simple-can-simulator \
+    "
+
+# Flutter
+IMAGE_INSTALL += "\
+    flutter-cluster-dashboard \
+    ${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", "flutter-cluster-dashboard-conf-demo", "flutter-cluster-dashboard-conf", d)} \
+    cluster-demo-config-flutter \
+    flutter-auto \
     "
 
 CLANGSDK = "1"