2nd part of the layer/profile rework [2/2]
[AGL/meta-agl-demo.git] / recipes-openivi / openivi-html5 / openivi-html5_git.bb
index 1e6a96b..168b98c 100644 (file)
@@ -6,20 +6,17 @@ LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4641e94ec96f98fabc56ff9cc48be14b"
 FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
 
 SRC_URI = " \
-       git://github.com/openivimobility/openivi-html5.git;branch=master;tag=7e5d9574758e504b194d16a52e04a1cfe4320138 \
+       git://github.com/openivimobility/openivi-html5.git;branch=master;tag=0b370eea8c7c852365bd717013a523b678abbdba \
        file://openivi-html5.sh \
        file://openivi-html5.service \
 "
 
 inherit pkgconfig cmake_qt5 externalsrc systemd
 PV = "0.1"
-PR = "r0"
 
 S = "${WORKDIR}/git"
 
-SYSTEMD_SERVICE_${PN} = "openivi-html5.service"
-
-RDEPENDS_${PN} = "qtbase qtwebkit"
+RDEPENDS_${PN} = "qtbase qtwebkit inputeventmanager windowmanager"
 DEPENDS = "qtbase-native qtbase qtwebkit"
 
 EXTRA_OECMAKE = " -DCMAKE_DISABLE_FIND_PACKAGE_X11=TRUE "
@@ -36,8 +33,11 @@ do_install() {
   install -p -D ${WORKDIR}/openivi-html5.sh ${D}${bindir}/openivi-html5.sh
 
   if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then
-    install -p -D ${WORKDIR}/openivi-html5.service ${D}${systemd_unitdir}/system/openivi-html5.service
+    install -d ${D}${systemd_user_unitdir}
+    install -p -D ${WORKDIR}/openivi-html5.service ${D}${systemd_user_unitdir}/openivi-html5.service
+    install -d ${D}${sysconfdir}/systemd/user/default.target.wants
+    ln -sf ${systemd_user_unitdir}/openivi-html5.service ${D}${sysconfdir}/systemd/user/default.target.wants
   fi
 }
 
-FILES_${PN} += " ${prefix}/bin/openivi-html5.sh"
+FILES_${PN} += " ${prefix}/bin/openivi-html5.sh ${systemd_user_unitdir} ${sysconfdir}"