Update to SPDX license names
[AGL/meta-agl-demo.git] / recipes-multimedia / openjtalk / openjtalk_1.09.bb
index 5ac0771..a5f7313 100644 (file)
@@ -1,7 +1,7 @@
 SUMMARY = "Open JTalk is a Japanese text-to-speech system."
 HOMEPAGE = "http://open-jtalk.sourceforge.net/"
 SECTION = "libs"
-LICENSE = "BSD"
+LICENSE = "BSD-3-Clause"
 
 LIC_FILES_CHKSUM = "file://COPYING;md5=ec9073c0ca40ff7c388b31cfd6a07a9e"
 
@@ -12,7 +12,7 @@ SRC_URI = "\
        file://fix-mecab-tool.patch \
        "
 
-SRC_URI_class-native = "\
+SRC_URI:class-native = "\
        http://downloads.sourceforge.net/open-jtalk/open_jtalk-${PV}.tar.gz \
        "
 
@@ -21,10 +21,10 @@ SRC_URI[md5sum] = "5dfdbad432d892f044fb96129a524bfe"
 SRC_URI[sha256sum] = "8ed79238d825fee1d9e0a1c6c8a89e2cc707189be1caa3fa79e8eb72436079d7"
 
 DEPENDS = " hts-engine openjtalk-native "
-DEPENDS_class-native = " hts-engine-native "
+DEPENDS:class-native = " hts-engine-native "
 
-RDEPENDS_${PN} = " openjtalk-voicedata "
-RDEPENDS_${PN}_class-native = " "
+RDEPENDS:${PN} = " openjtalk-voicedata "
+RDEPENDS:${PN}:class-native = " "
 
 inherit autotools-brokensep
 
@@ -36,14 +36,14 @@ EXTRA_OECONF = " \
  --with-hts-engine-library-path=${PKG_CONFIG_SYSROOT_DIR}/usr/lib \
 "
 
-EXTRA_OECONF_class-native = " \
+EXTRA_OECONF:class-native = " \
  --with-hts-engine-header-path=${includedir} \
  --with-hts-engine-library-path=${libdir} \
 "
 
-do_install_append_class-native() {
+do_install:append:class-native() {
        install -m 755 mecab/src/mecab-dict-index ${D}${bindir}
 }
 
-FILES_${PN} += " ${datadir}/dic/* "
+FILES:${PN} += " ${datadir}/dic/* "