sllin: update LIC_CHKSUM_FILE
[AGL/meta-agl-demo.git] / recipes-kernel / sllin / sllin.bb
index 6213fd9..59994d8 100644 (file)
@@ -1,6 +1,6 @@
 DESCRIPTION = "slLIN driver module"
 LICENSE = "GPLv2"
-LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+LIC_FILES_CHKSUM = "file://sllin.c;beginline=7;endline=37;md5=6408e14dba951f8cbe3c2a003a0d89d2"
 
 inherit module systemd
 
@@ -17,8 +17,10 @@ SRC_URI_append = " \
        file://0002_fix_null_operation_check.patch;pnum=2 \
        file://0003-Allow-recent-kernels-newer-4.11.x-to-build.patch;pnum=2 \
        file://0001-Disable-sllin-driver-debug-log.patch;pnum=2 \
+       file://0004-Fix-build-with-5.9-kernel.patch;pnum=2 \
        file://sllin-demo.service \
        file://start_lin_demo.sh \
+       file://lin_config.conf \
 "
 
 KERNEL_MODULE_AUTOLOAD_append = " sllin"
@@ -34,6 +36,10 @@ do_install_append () {
        install -m 755 ${WORKDIR}/start_lin_demo.sh ${D}/${bindir}/start_lin_demo.sh
        install -d ${D}${systemd_system_unitdir}
        install -m 0644 ${WORKDIR}/sllin-demo.service ${D}${systemd_system_unitdir}/
+       install -d ${D}${sysconfdir}
+       install -m 0644 ${WORKDIR}/lin_config.conf ${D}${sysconfdir}/
 }
 
-FILES_${PN}_append = " ${bindir}/start_lin_demo.sh"
+FILES_${PN} += "${bindir}/start_lin_demo.sh ${sysconfdir}/lin_config.conf"
+
+RDEPENDS_${PN} += "lin-config"