Convert most.bb to use KERNEL_MODULE_AUTOLOAD framework
[AGL/meta-agl-demo.git] / recipes-kernel / most / most.bb
index dd676c7..222c8aa 100644 (file)
@@ -7,26 +7,8 @@ inherit module
 PV = "0.1"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/most;protocol=https;branch=${AGL_BRANCH}"
-SRC_URI_append_porter = " file://0001-aim-network-3.10.31-ltsi-backport.patch \
-                          file://0001-aim-sound-3.10.31-ltsi-backport.patch \
-                        "
-S = "${WORKDIR}/git/driver"
-SRCREV = "${AGL_DEFAULT_REVISION}"
 
-# The inherit of module.bbclass will automatically name module packages with
-# "kernel-module-" prefix as required by the oe-core build environment.
+S = "${WORKDIR}/git/driver"
+SRCREV = "794e6dc552e626eb6dd506baf941873414d9ef73"
 
-do_install_append () {
-    # modprobe automatically at boot
-    if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
-        install -d ${D}${sysconfdir}/modules-load.d
-        echo "aim_cdev" > ${D}${sysconfdir}/modules-load.d/aim_cdev.conf
-        echo "aim_sound" > ${D}${sysconfdir}/modules-load.d/aim_sound.conf
-        echo "aim_network" > ${D}${sysconfdir}/modules-load.d/aim_network.conf
-        echo "aim_v4l2" > ${D}${sysconfdir}/modules-load.d/aim_v4l2.conf
-        echo "hdm_i2c" > ${D}${sysconfdir}/modules-load.d/hdm_i2c.conf
-        echo "hdm_dim2" > ${D}${sysconfdir}/modules-load.d/hdm_dim2.conf
-        echo "hdm_usb" > ${D}${sysconfdir}/modules-load.d/hdm_usb.conf
-        echo "mostcore" > ${D}${sysconfdir}/modules-load.d/mostcore.conf
-    fi
-}
+KERNEL_MODULE_AUTOLOAD += "aim_cdev aim_sound aim_network aim_v4l2 hdm_i2c hdm_dim2 hdm_usb mostcore"
\ No newline at end of file