recipes-kernel: add MOST driver kernel modules
[AGL/meta-agl-demo.git] / recipes-kernel / hdm-usb / hdm-usb.bb
diff --git a/recipes-kernel/hdm-usb/hdm-usb.bb b/recipes-kernel/hdm-usb/hdm-usb.bb
new file mode 100644 (file)
index 0000000..603ea32
--- /dev/null
@@ -0,0 +1,22 @@
+DESCRIPTION = "Example of how to build an external Linux kernel module"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
+                   file://hdm_usb.c;md5=ff660625252cda55e5bc409632fc8a78 \
+                  "
+
+inherit module
+
+PR = "r0"
+PV = "0.1"
+
+SRC_URI = "file://Makefile \
+          file://../../aim-network/files/networking.h \
+          file://../../mostcore/files/mostcore.h \
+          file://hdm_usb.c \
+          file://COPYING \
+         "
+
+S = "${WORKDIR}"
+
+# The inherit of module.bbclass will automatically name module packages with
+# "kernel-module-" prefix as required by the oe-core build environment.