recipes-kernel: add MOST driver kernel modules
[AGL/meta-agl-demo.git] / recipes-kernel / hdm-i2c / hdm-i2c.bb
diff --git a/recipes-kernel/hdm-i2c/hdm-i2c.bb b/recipes-kernel/hdm-i2c/hdm-i2c.bb
new file mode 100644 (file)
index 0000000..369104a
--- /dev/null
@@ -0,0 +1,21 @@
+DESCRIPTION = "Example of how to build an external Linux kernel module"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
+                   file://hdm_i2c.c;md5=823b7225682e904bdb79abd3b8777919 \  
+                  "
+
+inherit module
+
+PR = "r0"
+PV = "0.1"
+
+SRC_URI = "file://Makefile \
+          file://../../mostcore/files/mostcore.h \
+          file://hdm_i2c.c \
+          file://COPYING \
+         "
+
+S = "${WORKDIR}"
+
+# The inherit of module.bbclass will automatically name module packages with
+# "kernel-module-" prefix as required by the oe-core build environment.