Remove systemd user session and clean up packagegroups and images
[AGL/meta-agl-demo.git] / recipes-graphics / wayland / weston-terminal-conf.bb
index 4bf864f..390edc8 100644 (file)
@@ -2,19 +2,20 @@ SUMMARY = "AGL user session"
 LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
 
-SRC_URI = " \
-    file://weston-terminal.desktop \
-"
+inherit allarch agl-app
 
-inherit allarch
+AGL_APP_ID = "org.freedesktop.weston.wayland-terminal"
+AGL_APP_EXEC = "weston-terminal"
+AGL_APP_NAME = "Weston Terminal"
 
 do_install() {
-    install -d ${D}${datadir}/applications
-    install -m 0644 ${WORKDIR}/weston-terminal.desktop ${D}${datadir}/applications
+    # Enable systemd sandboxing override as a demonstration
+    install -d ${D}${systemd_system_unitdir}/agl-app@${AGL_APP_ID}.service.d/
+    ln -sf ${systemd_system_unitdir}/sandboxing/no-network.conf ${D}${systemd_system_unitdir}/agl-app@${AGL_APP_ID}.service.d/
 }
 
-FILES:${PN} = "${datadir}/applications"
-
-RDEPENDS:${PN} = " \
-    weston \
+FILES:${PN} = " \
+    ${sysconfdir}/systemd/system/agl-app@${AGL_APP_ID}.service.d \
 "
+
+RDEPENDS:${PN} = "weston-terminal"