ttf-dejavu: remove emoji glyphs from dejavu fonts
[AGL/meta-agl-demo.git] / recipes-graphics / ttf-fonts / ttf-dejavu_%.bbappend
diff --git a/recipes-graphics/ttf-fonts/ttf-dejavu_%.bbappend b/recipes-graphics/ttf-fonts/ttf-dejavu_%.bbappend
new file mode 100644 (file)
index 0000000..bf79e94
--- /dev/null
@@ -0,0 +1,15 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/files:"
+DEPENDS += "fontforge-native"
+
+# From the orginal work located at https://aur.archlinux.org/packages/ttf-dejavu-emojiless/
+
+SRC_URI_append = "\
+    file://cleaner.py \
+    file://emoji.json \
+    "
+
+do_install_prepend() {
+    for TTF in ${S}/*.ttf; do
+        fontforge -script ${WORKDIR}/cleaner.py ${TTF}
+    done
+}