recipes-demo-hmi: vod-server: use fix SRCREV
[AGL/meta-agl-demo.git] / recipes-demo-hmi / unicens / unicens_0.1.bb
index 0fc0afc..4f289c6 100644 (file)
@@ -8,7 +8,7 @@ PV = "0.1"
 
 DEPENDS += "libxml2"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/unicens;protocol=https"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/unicens;protocol=https;branch=${AGL_BRANCH}"
 SRC_URI += "file://0001-Fix-cross-compilation-with-yocto.patch"
 SRC_URI += "file://0001-Support-booting-by-systemd.patch \
             file://most-network-startup.service \
@@ -16,7 +16,7 @@ SRC_URI += "file://0001-Support-booting-by-systemd.patch \
 
 S = "${WORKDIR}/git"
 #SRCREV = "8c5f2324d7aa61669324aec1a0ad091fe1379489"
-SRCREV = "${AUTOREV}"
+SRCREV = "${AGL_DEFAULT_REVISION}"
 
 do_install() {
     install -m 0755 -d ${D}/usr/AGL/most
@@ -34,9 +34,9 @@ do_install() {
 
         # Execute install manually for root user on behalf of systemctl script
         # because it doesn't support user mode of systemd.
-        install -m 0755 -d ${D}/home/root/.config/systemd/user/default.target.wants/
-        ln -sf ${systemd_user_unitdir}/most-network-startup.service ${D}/home/root/.config/systemd/user/default.target.wants/most-network-startup.service
-        ln -sf ${systemd_user_unitdir}/most-network-manager.service ${D}/home/root/.config/systemd/user/default.target.wants/most-network-manager.service
+        install -m 0755 -d ${D}${ROOT_HOME}/.config/systemd/user/default.target.wants/
+        ln -sf ${systemd_user_unitdir}/most-network-startup.service ${D}${ROOT_HOME}/.config/systemd/user/default.target.wants/most-network-startup.service
+        ln -sf ${systemd_user_unitdir}/most-network-manager.service ${D}${ROOT_HOME}/.config/systemd/user/default.target.wants/most-network-manager.service
     fi
 }
 
@@ -44,6 +44,6 @@ FILES_${PN} += " \
     /usr/AGL/most \
     ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_user_unitdir}/most-network-startup.service', '', d)} \
     ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_user_unitdir}/most-network-manager.service', '', d)} \
-    ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '/home/root/.config/systemd/user/default.target.wants/most-network-startup.service', '', d)} \
-    ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '/home/root/.config/systemd/user/default.target.wants/most-network-manager.service', '', d)} \
+    ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${ROOT_HOME}/.config/systemd/user/default.target.wants/most-network-startup.service', '', d)} \
+    ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${ROOT_HOME}/.config/systemd/user/default.target.wants/most-network-manager.service', '', d)} \
     "