Make sure app recipes use the release versions
[AGL/meta-agl-demo.git] / recipes-demo-hmi / settings / settings_git.bb
index af22a0a..1bc4f6e 100644 (file)
@@ -7,7 +7,9 @@ LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/settings;protocol=https;branch=dab"
-SRCREV  = "72185231c33099b00bfb98f27175a6e225c9ab64"
+SRCREV  = "32be14bbc8f05abaf7ef5cb3e96469afc193d1f0"
+SRCREV_dab = "refs/tags/${DISTRO_BRANCH_VERSION_TAG}"
+
 
 PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
@@ -15,4 +17,9 @@ S  = "${WORKDIR}/git"
 # build-time dependencies
 DEPENDS += "qtquickcontrols2"
 
+# runtime dependencies
+RDEPENDS_${PN} += " \
+            agl-service-bluetooth \
+            agl-service-wifi"
+
 inherit qmake5 aglwgt