Change poiapp to use LICENSE
[AGL/meta-agl-demo.git] / recipes-demo-hmi / navigation / poiapp_git.bb
index 0249ce9..2942bf0 100644 (file)
@@ -4,20 +4,18 @@ HOMEPAGE    = "https://github.com/AGLExport/genivi-navi-yelp-client"
 SECTION     = "apps"
 
 LICENSE          = "GPLv2"
-LIC_FILES_CHKSUM = "file://COPYING;md5=947b2d60ca3872e172034438e9801200"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4ee23c52855c222cba72583d301d2338"
 
-inherit cmake_qt5 pkgconfig
-inherit aglwgt
-
-DEPENDS += " qtbase json-c libnaviapi-agl \
+DEPENDS += "qtbase json-c \
+            libhomescreen \
+            libqtappfw \
            "
 
-RDEPENDS_${PN} =  " qtbase \
-                  "
-
-SRCREV = "833cdb678636677c33088d67f9ebfdb6125ca900"
-SRC_URI = "git://github.com/AGLExport/genivi-navi-yelp-client.git;branch=eel \
-          "
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/poi-yelp;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
 
 S = "${WORKDIR}/git"
 
+inherit cmake_qt5 pkgconfig aglwgt
+
+RDEPENDS_${PN} =  "qtbase libqtappfw"