Unify locations of applications and demo
[AGL/meta-agl-demo.git] / recipes-demo-hmi / navigation / navigation_git.bb
old mode 100755 (executable)
new mode 100644 (file)
index 89bf4d0..6a052c0
@@ -4,12 +4,12 @@ LIC_FILES_CHKSUM="file://LICENSE;md5=3595e9c703a847d990664d2b396a9df0 \
 
 DEPENDS = " \
           glib-2.0 freetype sqlite3 wayland zlib expat openssl virtual/libgles2 virtual/libgl virtual/egl \
-          wayland \
+          wayland libdbus-c++ \
           "
 
 RDEPENDS_${PN} = " flite openjtalk "
 
-SRCREV="153f9d7ecb652732b1acc1cb00919c6a6af5556e"
+SRCREV="1b7218335b5b7a5312e3611138c70c49a27a3b9f"
 SRC_URI="git://github.com/AGLExport/gpsnavi.git \
          file://flite.in \
          file://jtalk.in \
@@ -34,11 +34,10 @@ do_install_append() {
    install -m 0755 ${D}/usr/bin/navi ${WORKDIR}/widget
    zip -ju ${WORKDIR}/widget/navigation.wgt ${WORKDIR}/widget/navi ${WORKDIR}/widget/config.xml
 
-   install -d ${D}/usr/AGL/ces2017-demo
-   install -m 0644 ${WORKDIR}/widget/navigation.wgt ${D}/usr/AGL/ces2017-demo/
-   install -d ${D}/usr/AGL/ces2017-demo
+   install -d ${D}/usr/AGL/apps
+   install -m 0644 ${WORKDIR}/widget/navigation.wgt ${D}/usr/AGL/apps/
 
    install -d ${D}/usr/share/mapdata
 }
 
-FILES_${PN} += " /usr/AGL/ces2017-demo/navigation.wgt /usr/share/mapdata "
+FILES_${PN} += " /usr/AGL/apps/navigation.wgt /usr/share/mapdata "