Add recipe for mapviewer
[AGL/meta-agl-demo.git] / recipes-demo-hmi / navigation / mapviewer_git.bb
diff --git a/recipes-demo-hmi/navigation/mapviewer_git.bb b/recipes-demo-hmi/navigation/mapviewer_git.bb
new file mode 100644 (file)
index 0000000..0078f3a
--- /dev/null
@@ -0,0 +1,21 @@
+LICENSE="GPLv2"
+LIC_FILES_CHKSUM="file://LICENSE;md5=3595e9c703a847d990664d2b396a9df0 \
+                  file://COPYING;md5=947b2d60ca3872e172034438e9801200"
+
+DEPENDS = " \
+          glib-2.0 freetype sqlite3 wayland zlib expat openssl virtual/libgles2 virtual/libgl virtual/egl \
+          wayland \
+          "
+
+RDEPENDS_${PN} = " navigation "
+
+SRCREV="348edb91ab6ea94e0d60c5a1789e1e9c2ae961c6"
+SRC_URI="git://github.com/AGLExport/mapviwer.git"
+
+# To avoid C++ library link failure
+SECURITY_CFLAGS = ""
+
+inherit autotools pkgconfig
+
+S = "${WORKDIR}/git"
+