Integration Low CAN demo and High Lvl ViWi.
[AGL/meta-agl-demo.git] / recipes-demo-hmi / low-can-demo / low-can-demo_git.bb
diff --git a/recipes-demo-hmi/low-can-demo/low-can-demo_git.bb b/recipes-demo-hmi/low-can-demo/low-can-demo_git.bb
new file mode 100644 (file)
index 0000000..6b8f6b5
--- /dev/null
@@ -0,0 +1,19 @@
+SUMMARY     = "Low CAN demo HTTP5 UI"
+DESCRIPTION = "AGL HTTP5 UI to display car metric (speed, rpm, ...) on AGL Distribution"
+HOMEPAGE    = "https://github.com/iotbzh/low-can-demo"
+
+LICENSE     = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=e3fc50a88d0a364313df4b21ef20c29e"
+
+SRC_URI = "gitsm://github.com/iotbzh/low-can-demo.git;protocol=https"
+SRCREV  = "df5cf4027d1978bd3ac37d583e711f134dd4a406"
+
+PV = "4.0+git${SRCPV}"
+S  = "${WORKDIR}/git"
+
+# Run-time dependencies
+RDEPENDS_${PN} += " low-level-can-service"
+
+inherit cmake aglwgt
+
+AGLWGT_AUTOINSTALL_${PN} := "0"