Add PROVIDES into libhomescreen bb files
[AGL/meta-agl-demo.git] / recipes-demo-hmi / libhomescreen / libhomescreen_git.bb
index 440ea42..b71b5b4 100644 (file)
@@ -3,21 +3,22 @@ DESCRIPTION = "libhomescreen"
 HOMEPAGE    = "http://docs.automotivelinux.org"
 LICENSE     = "Apache-2.0"
 SECTION     = "libs"
-S           = "${WORKDIR}/git/"
 
 BBCLASSEXTEND = " nativesdk"
 
-inherit qmake5 pkgconfig
+LIC_FILES_CHKSUM = "file://libhomescreen/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
 DEPENDS += " glib-2.0 "
 
-LIC_FILES_CHKSUM = "file://libhomescreen/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
-SRCREV  = "${AUTOREV}"
-# PV needs to be modified with SRCPV to work AUTOREV correctly
-PV = "0.0+git${SRCPV}"
+inherit qmake5 pkgconfig
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/src/libhomescreen.git;protocol=http \
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/src/libhomescreen.git;protocol=https;branch=${AGL_BRANCH} \
            file://homescreen.pc.in"
+SRCREV  = "f5c14333d2170ae9babed53ea530828569a830ff"
+S       = "${WORKDIR}/git/"
+
+# PV needs to be modified with SRCPV to work AUTOREV correctly
+PV = "0.0+git${SRCPV}"
 
 do_install() {
     install -d ${D}/usr/AGL/${PN}
@@ -62,4 +63,4 @@ FILES_libhomescreensampleapp-dbg += "/usr/AGL/${PN}/.debug"
 
 
 RDEPENDS_libhomescreensampleapp-dbg += "${PN}-dbg ${PN}-dev"
-
+PROVIDES += "virtual/libhomescreen"