Fix typo in homescreen recipe
[AGL/meta-agl-demo.git] / recipes-demo-hmi / homescreen / homescreen_git.bb
index f9b02e9..bfdf06e 100644 (file)
@@ -3,19 +3,21 @@ DESCRIPTION = "AGL Home Screen Application build with recipe method"
 HOMEPAGE    = "http://docs.automotivelinux.org"
 LICENSE     = "Apache-2.0"
 SECTION     = "apps"
-LIC_FILES_CHKSUM = "file://homescreen/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
 DEPENDS = "\
         qtbase \
         qtdeclarative \
         qtquickcontrols2 \
-        pulseaudio \
-        agl-service-homescreen-2017 \
-        agl-service-windowmanager-2017 \
+        agl-service-homescreen \
         agl-service-weather \
         libqtappfw \
-        qlibwindowmanager \
-        virtual/libhomescreen \
+        libhomescreen \
+        libafb-helpers-qt \
+        wayland-native \
+        wayland \
+        qtwayland \
+        qtwayland-native \
 "
 
 inherit qmake5 systemd pkgconfig aglwgt
@@ -27,3 +29,9 @@ PV      = "1.0+git${SRCPV}"
 S       = "${WORKDIR}/git/"
 
 PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
+
+OE_QMAKE_CXXFLAGS_append = " ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', '' , '-DQT_NO_DEBUG_OUTPUT', d)}"
+
+RDEPENDS_${PN} += " \
+        libqtappfw \
+"