These recipes were in need of a repin for chinook 3.0.2
[AGL/meta-agl-demo.git] / recipes-demo-hmi / homescreen / homescreen_git.bb
index 2115804..76e5ff2 100644 (file)
@@ -1,15 +1,27 @@
 SUMMARY     = "AGL Home Screen Application"
 DESCRIPTION = "AGL Home Screen Application + SampleAppTimeDate + HomeScreenAppFrameworkBinderAGL + WindowManager + InputEventManager"
 HOMEPAGE    = "https://wiki.automotivelinux.org/homescreen"
-LICENSE     = "Apache-2.0"
 SECTION     = "apps"
-S           = "${WORKDIR}/git/"
 
-BBCLASSEXTEND = " nativesdk"
+LICENSE     = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://HomeScreen/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
-inherit qmake5 systemd pkgconfig
-DEPENDS = " qtbase "
 
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/staging/HomeScreen.git;protocol=http \
+           file://homescreen.pc.in \
+           file://dbus-homescreen.conf.in"
+SRCREV  = "${AUTOREV}"
+
+# Pinned SRCREV for Charming Chinook, staging projects do not follow release branches
+SRCREV_chinook = "3b5d0701a25b19ee2ac91d7466652c8fc4025db0"
+
+
+# PV needs to be modified with SRCPV to work AUTOREV correctly
+PV = "0.0+git${SRCPV}"
+# git repository used
+S           = "${WORKDIR}/git/"
+
+DEPENDS += " qtbase "
 # for HomeScreenAppFrameworkBinderTizen:
 #DEPENDS += " pkgmgr-info aul "
 # for WindowManager:
@@ -19,14 +31,9 @@ DEPENDS += " glib-2.0 "
 # for sample apps
 DEPENDS += " qtdeclarative qtquickcontrols2 "
 
-LIC_FILES_CHKSUM = "file://HomeScreen/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
-SRCREV  = "${AUTOREV}"
-# PV needs to be modified with SRCPV to work AUTOREV correctly
-PV = "0.0+git${SRCPV}"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/staging/HomeScreen.git;protocol=http \
-           file://homescreen.pc.in \
-           file://dbus-homescreen.conf.in"
+inherit qmake5 systemd pkgconfig
+
 
 PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
 
@@ -95,3 +102,5 @@ RDEPENDS_libhomescreen-dbg += "${PN}-dbg libhomescreen-dev"
 
 RDEPENDS_${PN}-dev += "libhomescreen-dev"
 
+
+BBCLASSEXTEND = " nativesdk"