Make sure app recipes use the release versions
[AGL/meta-agl-demo.git] / recipes-demo-hmi / homescreen / homescreen_git.bb
index ee4d03b..331a930 100644 (file)
@@ -6,20 +6,24 @@ SECTION     = "apps"
 S           = "${WORKDIR}/git/"
 
 inherit qmake5 systemd pkgconfig
-DEPENDS = " qtbase qtdeclarative qtquickcontrols2 "
+DEPENDS = " qtbase qtdeclarative qtquickcontrols2 pulseaudio"
 RDEPENDS_${PN} = " \
        homescreenappframeworkbinderagl \
        inputeventmanager \
        windowmanager"
 
 LIC_FILES_CHKSUM = "file://homescreen/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
-SRCREV  = "${AUTOREV}"
-# PV needs to be modified with SRCPV to work AUTOREV correctly
-PV = "0.0+git${SRCPV}"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/apps/homescreen.git;protocol=http \
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/p/apps/homescreen.git;protocol=https;branch=dab \
            file://dbus-homescreen.conf.in"
 
+SRCREV  = "b9889b160ecc43dcde07fe9d8a96373196c539ab"
+SRCREV_dab = "refs/tags/${DISTRO_BRANCH_VERSION_TAG}"
+
+
+# PV needs to be modified with SRCPV to work AUTOREV correctly
+PV = "0.0+git${SRCPV}"
+
 PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
 
 do_install() {