Use ROOT_HOME variable, not /home/root
[AGL/meta-agl-demo.git] / recipes-demo-hmi / can-lin / can-lin_0.2.bb
index b12bc0f..918b868 100644 (file)
@@ -2,12 +2,15 @@ DESCRIPTION = "CAN-LIN Application"
 LICENSE = "GPLv2"
 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/most-can-demo-bin;protocol=https"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/staging/most-can-demo-bin;protocol=https;branch=${AGL_BRANCH}"
 SRC_URI += "file://hvac-demo.service"
 
 S = "${WORKDIR}/git"
 SRCREV = "fd2101e277cb80eef4c6381924cfdc1d50087d12"
 
+# These binaries are currently for the porter kernel only
+COMPATIBLE_MACHINE = "porter"
+
 do_install() {
         install -m 0755 -d ${D}${bindir}
         install -m 0755 ${S}/OptoLyzerMoccaApp ${D}${bindir}
@@ -24,13 +27,13 @@ do_install() {
 
         # Execute install manually for root user on behalf of systemctl script
         # because it doesn't support user mode of systemd.
-        install -m 0755 -d ${D}/home/root/.config/systemd/user/default.target.wants/
-        ln -sf ${systemd_user_unitdir}/hvac-demo.service ${D}/home/root/.config/systemd/user/default.target.wants/hvac-demo.service
+        install -m 0755 -d ${D}${ROOT_HOME}/.config/systemd/user/default.target.wants/
+        ln -sf ${systemd_user_unitdir}/hvac-demo.service ${D}${ROOT_HOME}/.config/systemd/user/default.target.wants/hvac-demo.service
 }
 
 FILES_${PN} += " \
     ${bindir}/OptoLyzerMoccaApp \
     /usr/AGL/most/vod-client \
     ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${systemd_user_unitdir}/hvac-demo.service', '', d)} \
-    ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '/home/root/.config/systemd/user/default.target.wants/hvac-demo.service', '', d)} \
+    ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '${ROOT_HOME}/.config/systemd/user/default.target.wants/hvac-demo.service', '', d)} \
     "