agl-service-mediaplayer: enable 4A support if configured
[AGL/meta-agl-demo.git] / recipes-demo-hmi / agl-service-mediaplayer / agl-service-mediaplayer_git.bb
index 8e69da4..d4da7f2 100644 (file)
@@ -6,8 +6,8 @@ SECTION     = "apps"
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
-SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/agl-service-mediaplayer;protocol=http"
-SRCREV  = "${AUTOREV}"
+SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/agl-service-mediaplayer;protocol=https;branch=${AGL_BRANCH}"
+SRCREV  = "${AGL_APP_REVISION}"
 
 PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
@@ -16,3 +16,5 @@ DEPENDS = "json-c gstreamer1.0 gstreamer1.0-plugins-base"
 RDEPENDS_${PN} = "agl-service-mediascanner gstreamer1.0-plugins-bad-waylandsink"
 
 inherit cmake aglwgt pkgconfig
+
+EXTRA_OECMAKE += "${@bb.utils.contains('DISTRO_FEATURES', 'agl-audio-4a-framework', '-DHAVE_4A_FRAMEWORK=1' , '', d)}"