openivi-html5.sh: Configure HTML5 application
[AGL/meta-agl-demo.git] / recipes-demo-hmi / HomeScreen / HomeScreen_0.6.2.bb
index e5e71fc..957dfdb 100644 (file)
@@ -15,6 +15,8 @@ DEPENDS = " qtbase "
 DEPENDS += " wayland-ivi-extension "
 # for libhomescreen
 DEPENDS += " glib-2.0 "
+# for sample apps
+DEPENDS += " qtdeclarative "
 
 LIC_FILES_CHKSUM = "file://HomeScreen/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 SRCREV  = "7f06418646c8822452f8541386810208c523f990"
@@ -46,10 +48,10 @@ do_install() {
     ln -sf ${libdir}/libhomescreen.so.1.0.0 ${D}${libdir}/libhomescreen.so.1.0
 
     install -d ${D}${systemd_unitdir}/system
-    install -m 0644 ${B}/HomeScreen/conf/HomeScreen.service ${D}${systemd_unitdir}/system
-    install -m 0644 ${B}/HomeScreenAppFrameworkBinderAGL/conf/HomeScreenAppFrameworkBinderAGL.service ${D}${systemd_unitdir}/system
-    install -m 0644 ${B}/InputEventManager/conf/InputEventManager.service ${D}${systemd_unitdir}/system
-    install -m 0644 ${B}/WindowManager/conf/WindowManager.service ${D}${systemd_unitdir}/system
+    install -m 0644 ${S}/HomeScreen/conf/HomeScreen.service ${D}${systemd_unitdir}/system
+    install -m 0644 ${S}/HomeScreenAppFrameworkBinderAGL/conf/HomeScreenAppFrameworkBinderAGL.service ${D}${systemd_unitdir}/system
+    install -m 0644 ${S}/InputEventManager/conf/InputEventManager.service ${D}${systemd_unitdir}/system
+    install -m 0644 ${S}/WindowManager/conf/WindowManager.service ${D}${systemd_unitdir}/system
 }
 
 FILES_${PN} += "/usr/AGL/${PN}/ /usr/AGL/${PN}/colorschemes ${libdir} ${systemd_unitdir}/system"