These recipes were in need of a repin for chinook 3.0.2
[AGL/meta-agl-demo.git] / recipes-demo-hmi / CES2017-demo / CES2017-demo.bb
index 777f98e..e96c98f 100644 (file)
 SUMMARY     = "App Launcher for the AGL Demonstrator @ CES2017"
 DESCRIPTION = "App Lanucher app in QML format for the AGL Demonstrator @ CESS2017"
 HOMEPAGE    = "https://git.automotivelinux.org/gerrit/#/admin/projects/AGL/DemoApps/CES2017"
-LICENSE     = "MPL-2.0"
 SECTION     = "apps"
-PV          = "1.0+git${SRCPV}"
-S           = "${WORKDIR}/git/"
-PN          = "ces2017-demo"
-
-inherit qmake5
-DEPENDS = "homescreen zip-native qtmultimedia qtquickcontrols2"
-
+LICENSE     = "MPL-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=815ca599c9df247a0c7f619bab123dad"
 
-SRC_URI     = "git://gerrit.automotivelinux.org/gerrit/AGL/DemoApps/CES2017;protocol=http"
-SRCREV      = "${AUTOREV}"
-
-
-RDEPENDS_${PN} += " \
-    qtmultimedia-qmlplugins \
-    qtmultimedia-rtlfm-radio-plugin \
-    qtquickcontrols-qmlplugins \
-    qtquickcontrols2-qmlplugins \
-    qtsvg-plugins \
-    "
-
-do_install_prepend() {
-    echo "<?xml version=\"1.0\" encoding=\"UTF-8\"?> \
-<widget xmlns=\"http://www.w3.org/ns/widgets\" id=\"controls\" version=\"0.1\"> \
-  <name>Controls</name> \
-  <content src=\"controls\" type=\"application/x-executable\"/> \
-  <description>Controls app.</description> \
-  <author>Qt</author> \
-  <icon src=\"controls.png\"/> \
-  <license>Apache 2.0</license> \
-</widget> \
-" > ${B}/apps/Controls/config.xml
-
-    cd ${B}/apps/Controls/
-    zip controls.wgt config.xml controls
-
-
-
-    echo "<?xml version=\"1.0\" encoding=\"UTF-8\"?> \
-<widget xmlns=\"http://www.w3.org/ns/widgets\" id=\"dashboard\" version=\"0.1\"> \
-  <name>Dashboard</name> \
-  <content src=\"dashboard\" type=\"application/x-executable\"/> \
-  <description>Dashboard app.</description> \
-  <author>Qt</author> \
-  <icon src=\"dashboard.png\"/> \
-  <license>Apache 2.0</license> \
-</widget> \
-" > ${B}/apps/Dashboard/config.xml
-
-    cd ${B}/apps/Dashboard/
-    zip dashboard.wgt config.xml dashboard
-
-
-
-    echo "<?xml version=\"1.0\" encoding=\"UTF-8\"?> \
-<widget xmlns=\"http://www.w3.org/ns/widgets\" id=\"phone\" version=\"0.1\"> \
-  <name>Phone</name> \
-  <content src=\"phone\" type=\"application/x-executable\"/> \
-  <description>Phone app.</description> \
-  <author>Qt</author> \
-  <icon src=\"phone.png\"/> \
-  <license>Apache 2.0</license> \
-</widget> \
-" > ${B}/apps/Phone/config.xml
-
-    cd ${B}/apps/Phone/
-    zip phone.wgt config.xml phone
-
-
+DEPENDS = "homescreen zip-native qtmultimedia qtquickcontrols2"
 
-    echo "<?xml version=\"1.0\" encoding=\"UTF-8\"?> \
-<widget xmlns=\"http://www.w3.org/ns/widgets\" id=\"radio\" version=\"0.1\"> \
-  <name>Radio</name> \
-  <content src=\"radio\" type=\"application/x-executable\"/> \
-  <description>Radio app.</description> \
-  <author>Qt</author> \
-  <icon src=\"radio.png\"/> \
-  <license>Apache 2.0</license> \
-</widget> \
-" > ${B}/apps/Radio/config.xml
+PV = "1.0+git${SRCPV}"
+PN = "ces2017-demo"
 
-    cd ${B}/apps/Radio/
-    zip radio.wgt config.xml radio
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/AGL/DemoApps/CES2017;protocol=http"
+SRCREV = "${AUTOREV}"
 
+# Pinned branch/SRCREV for Charming Chinook
+SRC_URI_chinook = "git://gerrit.automotivelinux.org/gerrit/AGL/DemoApps/CES2017;protocol=http;branch=chinook"
+SRCREV_chinook = "f31423226ad2baf75a770d41dae1b0ec42bf7ff1"
 
+S = "${WORKDIR}/git/"
 
-    cat > ${B}/apps/installAllApps.sh <<-EOF
-       #!/bin/sh
-       /usr/bin/afm-util install controls.wgt
-       /usr/bin/afm-util install dashboard.wgt
-       /usr/bin/afm-util install phone.wgt
-       /usr/bin/afm-util install radio.wgt
-       /usr/bin/afm-util install settings.wgt
-       /usr/bin/afm-util install navigation.wgt
-       EOF
-}
+inherit qmake5
 
 do_install() {
-    install -d ${D}/usr/AGL/${PN}
-    install -m 0644 ${B}/apps/Controls/controls.wgt ${D}/usr/AGL/${PN}/
-    install -m 0644 ${B}/apps/Dashboard/dashboard.wgt ${D}/usr/AGL/${PN}/
-    install -m 0644 ${B}/apps/Phone/phone.wgt ${D}/usr/AGL/${PN}/
-    install -m 0644 ${B}/apps/Radio/radio.wgt ${D}/usr/AGL/${PN}/
-
-    install -m 0755 ${B}/apps/installAllApps.sh ${D}/usr/AGL/${PN}/
-
     install -d ${D}${libdir}/qt5/qml/AGL/Demo/Controls/
     install -m 0644 ${S}/imports/AGL/Demo/Controls/qmldir ${D}${libdir}/qt5/qml/AGL/Demo/Controls/
     install -m 0644 ${S}/imports/AGL/Demo/Controls/ImageButton.qml ${D}${libdir}/qt5/qml/AGL/Demo/Controls/
@@ -131,13 +44,8 @@ do_install() {
     install -m 0644 ${S}/imports/qtquickcontrols2aglstyle/images/* ${D}${libdir}/qt5/qml/QtQuick/Controls.2/AGL/images/
 }
 
-# plain copy in own folder for now
-#do_install() {
-#    mkdir -p ${D}/usr/AGL/CES2017/
-#    cp -rf ./* ${D}/usr/AGL/CES2017/
-#}
-
-FILES_${PN} += "/usr/AGL/ \
+FILES_${PN} += " \
+       /usr/AGL/ \
        /usr/lib/qt5/qml/AGL/Demo/Controls/qmldir \
        /usr/lib/qt5/qml/AGL/Demo/Controls/ImageButton.qml \
        /usr/lib/qt5/qml/AGL/Demo/Controls/ToggleButton.qml \
@@ -152,4 +60,10 @@ FILES_${PN} += "/usr/AGL/ \
        /usr/lib/qt5/qml/AGL/Demo/Controls/images/Keyboard_Arrow.svg \
        /usr/lib/qt5/qml/QtQuick/Controls.2/AGL \
        /usr/lib/qt5/qml/QtQuick/Controls.2/AGL/images \
-       "
+"
+
+RDEPENDS_${PN} += " \
+       qtquickcontrols-qmlplugins \
+       qtquickcontrols2-qmlplugins \
+       qtsvg-plugins \
+"