fix recipes git source url
[AGL/meta-agl-demo.git] / recipes-demo-hmi / CES2016-demo / CES2016-demo.bb
index 48e242b..28c3df3 100644 (file)
@@ -4,13 +4,21 @@ HOMEPAGE    = "https://git.automotivelinux.org/gerrit/#/admin/projects/AGL/DemoA
 
 SECTION     = "apps"
 
+PN = "ces2016-demo"
+
 LICENSE     = "MPL-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=815ca599c9df247a0c7f619bab123dad"
 
-SRC_URI     = "git://git.automotivelinux.org/gerrit/AGL/DemoApps/CES2016;protocol=http"
-SRCREV      = "AUTOINC"
+SRC_URI     = "git://gerrit.automotivelinux.org/gerrit/AGL/DemoApps/CES2016;protocol=http"
+SRCREV      = "${AUTOREV}"
+
+PV = "1.0+git"
 
-RDEPENDS_${PN}_append = "qtmultimedia qtquickcontrols"
+RDEPENDS_${PN} += " \
+    qtmultimedia-qmlplugins \
+    qtquickcontrols-qmlplugins \
+    qtsvg-plugins \
+    "
 
 # custom configure and install as these are just qml files
 
@@ -23,8 +31,8 @@ do_configure() {
 
 # plain copy in own folder for now
 do_install() {
-    mkdir -p ${D}/opt/AGL/CES2016/
-    cp -ar ./* ${D}/opt/AGL/CES2016/
+    mkdir -p ${D}/usr/AGL/CES2016/
+    cp -rf ./* ${D}/usr/AGL/CES2016/
 }
 
-FILES_${PN} = "/opt/AGL/"
+FILES_${PN} = "/usr/AGL/"