Restore webapp samples
[AGL/meta-agl-demo.git] / recipes-demo / webapp-samples / html5-aquarium_git.bb
index 6ca90bc..7828ecc 100644 (file)
@@ -1,10 +1,16 @@
 SUMMARY     = "AGL HTML5 Aquarium Demo"
 LICENSE     = "BSD-3-Clause"
 LIC_FILES_CHKSUM = "file://aquarium/LICENSE;md5=9f0d95e61aa217eacd61ee6833cf411c"
-DESKTOP_FILE = "webapps-aquarium.desktop"
+APPINFO_FILE = "appinfo-aquarium.json"
 
 require webapp-samples.inc
 
+inherit pythonnative agl-app
+
+AGL_APP_TEMPLATE = "agl-app-web"
+AGL_APP_ID = "webapps-aquarium"
+AGL_APP_NAME = "Aquarium"
+
 do_install:append() {
   cp -R --no-dereference --preserve=mode,links ${S}/aquarium/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
 }