Update radio support in demo application
[AGL/meta-agl-demo.git] / recipes-demo / radio / radio_git.bb
index e4dd07c..d35b793 100644 (file)
@@ -3,7 +3,7 @@ DESCRIPTION = "AGL demonstration Radio application"
 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/radio"
 SECTION     = "apps"
 
-LICENSE     = "Apache-2.0 & GPLv2+"
+LICENSE     = "Apache-2.0 & GPL-2.0-or-later"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
 DEPENDS = "qtquickcontrols2 libqtappfw"
@@ -15,11 +15,13 @@ SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/radio;protocol=https;bra
            file://presets-CES.conf \
            file://presets-FOSDEM.conf \
 "
-SRCREV  = "${AGL_APP_REVISION}"
+SRCREV  = "6ae60dcb666e95dad881457cea03a7b72d15faf3"
 
 S  = "${WORKDIR}/git"
 
-inherit qmake5
+inherit qmake5 pkgconfig agl-app
+
+AGL_APP_NAME = "Radio"
 
 # ALS, CES, FOSDEM available
 AGL_RADIO_PRESETS_LOCALE ?= "CES"
@@ -31,6 +33,6 @@ do_install:append() {
     install -m 0644 ${WORKDIR}/presets-${AGL_RADIO_PRESETS_LOCALE}.conf ${D}${sysconfdir}/xdg/AGL/radio-presets.conf
 }
 
-FILES:${PN} += "${sysconfdir}/xdg/AGL/* ${datadir}/icons/"
+FILES:${PN} += "${sysconfdir}/xdg/AGL/*"
 
 RDEPENDS:${PN} += "libqtappfw"