Update radio support in demo application
[AGL/meta-agl-demo.git] / recipes-demo / radio / radio_git.bb
index fcbbd63..c9d8ed7 100644 (file)
@@ -15,11 +15,13 @@ SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/radio;protocol=https;bra
            file://presets-CES.conf \
            file://presets-FOSDEM.conf \
 "
-SRCREV  = "f48bb2aab34273bd5b3cc1f9f9d88afbfb231d6b"
+SRCREV  = "aef392d9df8bb5e4ada4b3f8f44016e8a839d154"
 
 S  = "${WORKDIR}/git"
 
-inherit qmake5 pkgconfig
+inherit qmake5 pkgconfig agl-app
+
+AGL_APP_NAME = "Radio"
 
 # ALS, CES, FOSDEM available
 AGL_RADIO_PRESETS_LOCALE ?= "CES"
@@ -31,12 +33,6 @@ do_install:append() {
     install -m 0644 ${WORKDIR}/presets-${AGL_RADIO_PRESETS_LOCALE}.conf ${D}${sysconfdir}/xdg/AGL/radio-presets.conf
 }
 
-# HACK: new systemd-enabled applaunchd for now relies on .desktop and DBusActivatable
-do_install:append() {
-    sed -n "/^DBusActivatable=/!p" -i ${D}${datadir}/applications/radio.desktop
-    echo "DBusActivatable=true" >> ${D}${datadir}/applications/radio.desktop
-}
-
-FILES:${PN} += "${sysconfdir}/xdg/AGL/* ${datadir}/icons/"
+FILES:${PN} += "${sysconfdir}/xdg/AGL/*"
 
 RDEPENDS:${PN} += "libqtappfw"