Remove usage of AGL_APP_REVISION
[AGL/meta-agl-demo.git] / recipes-demo / phone / phone_git.bb
index a878185..6c41859 100644 (file)
@@ -1,24 +1,22 @@
-SUMMARY     = "Phone for CES2017 AGL Demonstration"
-DESCRIPTION = "AGL HMI Application for demonstrating phone on AGL Distribution"
+SUMMARY     = "Phone application"
+DESCRIPTION = "AGL demonstration Phone application"
 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/phone"
 SECTION     = "apps"
 
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/phone;protocol=https;branch=${AGL_BRANCH}"
-SRCREV  = "${AGL_APP_REVISION}"
+DEPENDS = "qtquickcontrols2 libqtappfw gstreamer1.0"
 
 PV = "1.0+git${SRCPV}"
-S  = "${WORKDIR}/git"
 
-# build-time dependencies
-DEPENDS += "qtquickcontrols2 \
-            libqtappfw \
-            libhomescreen \
-            gstreamer1.0 \
-"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/phone;protocol=https;branch=${AGL_BRANCH}"
+SRCREV  = "067f1e0b7b1454922e09efada608410cd3b955b0"
+
+S = "${WORKDIR}/git"
+
+inherit qmake5
 
-inherit qmake5 aglwgt
+FILES:${PN} += "${datadir}/icons/ ${datadir}/sounds/"
 
-RDEPENDS_${PN} += "agl-service-telephony agl-service-bluetooth-pbap libqtappfw"
+RDEPENDS:${PN} += "libqtappfw"