sllin: switch to updated upstream
[AGL/meta-agl-demo.git] / recipes-demo / navigation / tbtnavi_git.bb
index d2e8e63..d052b67 100644 (file)
@@ -3,7 +3,7 @@ DESCRIPTION = "Demo AGL turn by turn cluster navigation application based on QtL
 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/admin/repos/apps/tbtnavi"
 SECTION     = "apps"
 
-LICENSE     = "Apache-2.0 & ISC & BSD-3-Clause & BSL-1.0"
+LICENSE = "Apache-2.0 & ISC & BSD-3-Clause & BSL-1.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984 \
                     file://LICENSE.mapbox-cheap-ruler-cpp;md5=761263ee6bdc98e8697d9fbc897021ba \
                     file://LICENSE.mapbox-geometry.hpp;md5=6e44f5d6aeec54f40fc84eebe3c6fc6c \
@@ -11,26 +11,26 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984 \
                     file://include/mapbox/recursive_wrapper.hpp;beginline=4;endline=13;md5=cd3341aae76c0cf8345935abd20f0051 \
 "
 
-DEPENDS += "qtbase \
-            qtquickcontrols2 \
-            qlibhomescreen \
-            qtlocation \
-            libqtappfw \
-            wayland-native \
-            qtwayland-native \
+DEPENDS = " \
+    qtbase \
+    qtquickcontrols2 \
+    qtlocation \
+    libqtappfw \
+    wayland-native \
+    qtwayland-native \
 "
 
-PV = "1.0+git${SRCPV}"
+PV = "2.0+git${SRCPV}"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/tbtnavi;protocol=https;branch=${AGL_BRANCH}"
-SRCREV = "${AGL_APP_REVISION}"
+SRCREV = "70dfe121582cda2c82c794e5af6550b5c1a237c4"
 
 S = "${WORKDIR}/git"
 
-inherit qmake5 aglwgt pkgconfig
+inherit qmake5 pkgconfig
 
-RDEPENDS_${PN} += "qtlocation \
-                   ondemandnavi-config \
-                   agl-service-navigation \
-                   libqtappfw \
+RDEPENDS:${PN} += " \
+    qtlocation \
+    ondemandnavi-config \
+    libqtappfw \
 "