Bump SRCREV for tbtnavi
[AGL/meta-agl-demo.git] / recipes-demo / navigation / tbtnavi_git.bb
index 7931353..1720e89 100644 (file)
@@ -16,8 +16,10 @@ DEPENDS = " \
     qtquickcontrols2 \
     qtlocation \
     libqtappfw \
-    wayland-native \
     qtwayland-native \
+    protobuf \
+    grpc \
+    grpc-native \
 "
 
 PV = "2.0+git${SRCPV}"
@@ -27,16 +29,16 @@ SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/tbtnavi;protocol=https;b
            file://tbtnavi.conf \
            file://tbtnavi.token \
 "
-SRCREV = "f923df9484ed34676dfcf022043f97d86a4bddfa"
+SRCREV = "f00c1e19f5c4cbcd185c8043f3062612bf1537f7"
 
 S = "${WORKDIR}/git"
 
-inherit qmake5 systemd pkgconfig
+inherit meson systemd pkgconfig
+
+SYSTEMD_SERVICE:${PN} = "${BPN}.service"
 
 do_install:append() {
-    install -d ${D}${systemd_user_unitdir}/agl-session.target.wants
-    install -m0644 ${WORKDIR}/tbtnavi.service ${D}${systemd_user_unitdir}/tbtnavi.service
-    ln -s ../tbtnavi.service ${D}${systemd_user_unitdir}/agl-session.target.wants/tbtnavi.service
+    install -D -m 0644 ${WORKDIR}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service
 
     # Currently using default global client and CA certificates
     # for KUKSA.val SSL, installing app specific ones would go here.
@@ -50,8 +52,6 @@ do_install:append() {
     install -m 0644 ${WORKDIR}/tbtnavi.token ${D}${sysconfdir}/xdg/AGL/tbtnavi/
 }
 
-FILES:${PN} += " ${systemd_user_unitdir}"
-
 RDEPENDS:${PN} += " \
     qtlocation \
     ondemandnavi-config \