Switch Qt demo to KUKSA.val databroker
[AGL/meta-agl-demo.git] / recipes-demo / navigation / ondemandnavi_git.bb
index da19802..3baac2a 100644 (file)
@@ -14,11 +14,14 @@ SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/ondemandnavi;protocol=ht
            file://navigation.conf \
            file://navigation.token \
 "
-SRCREV = "1a014832f3da70e413650e0eeb4f40e598feb257"
+SRCREV = "d6b883ef6bdb63fb501b03d64c9a32bc29b7b2c7"
 
 S = "${WORKDIR}/git"
 
-inherit qmake5 pkgconfig
+inherit qmake5 pkgconfig agl-app
+
+AGL_APP_ID = "navigation"
+AGL_APP_NAME = "Navigation"
 
 do_install:append() {
     # Currently using default global client and CA certificates
@@ -33,8 +36,6 @@ do_install:append() {
     install -m 0644 ${WORKDIR}/navigation.token ${D}${sysconfdir}/xdg/AGL/navigation/
 }
 
-FILES:${PN} += "${datadir}/icons/"
-
 RDEPENDS:${PN} += " \
     qtlocation \
     flite \