Add updated demo applications back
[AGL/meta-agl-demo.git] / recipes-demo / navigation / ondemandnavi_git.bb
diff --git a/recipes-demo/navigation/ondemandnavi_git.bb b/recipes-demo/navigation/ondemandnavi_git.bb
new file mode 100644 (file)
index 0000000..3b9fce4
--- /dev/null
@@ -0,0 +1,29 @@
+SUMMARY     = "Navigation application."
+DESCRIPTION = "AGL demonstration Navigation application based on QtLocation widget."
+HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/ondemandnavi"
+SECTION     = "apps"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS = "qtquickcontrols2 qtlocation libqtappfw"
+
+PV = "2.0+git${SRCPV}"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/ondemandnavi;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+S = "${WORKDIR}/git"
+
+inherit qmake5 pkgconfig
+
+FILES:${PN} += "${datadir}/icons/"
+
+RDEPENDS:${PN} += " \
+    qtlocation \
+    flite \
+    libqtappfw \
+    openjtalk \
+    gstreamer1.0 \
+    ondemandnavi-config \
+"