Remove usage of AGL_APP_REVISION
[AGL/meta-agl-demo.git] / recipes-demo / messaging / messaging_git.bb
index fbdff55..65959b3 100644 (file)
@@ -6,18 +6,17 @@ SECTION     = "apps"
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/messaging;protocol=https;branch=${AGL_BRANCH}"
-SRCREV  = "${AGL_APP_REVISION}"
+DEPENDS = "qtquickcontrols2 libqtappfw"
 
 PV = "1.0+git${SRCPV}"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/messaging;protocol=https;branch=${AGL_BRANCH}"
+SRCREV  = "b895fde2c991117f910a62b54072dcad348b166e"
+
 S  = "${WORKDIR}/git"
 
-# build-time dependencies
-DEPENDS += "qtquickcontrols2 \
-            libqtappfw \
-            libhomescreen \
-"
+inherit qmake5
 
-inherit qmake5 aglwgt
+FILES:${PN} += "${datadir}/icons/"
 
-RDEPENDS_${PN} += "agl-service-bluetooth-map libqtappfw"
+RDEPENDS:${PN} += "libqtappfw"