Update demo app runtime dependencies
[AGL/meta-agl-demo.git] / recipes-demo / messaging / messaging_git.bb
index fbdff55..5d5e7a6 100644 (file)
@@ -6,18 +6,15 @@ SECTION     = "apps"
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
+DEPENDS = "qtquickcontrols2 libqtappfw"
+
+PV = "1.0+git${SRCPV}"
+
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/messaging;protocol=https;branch=${AGL_BRANCH}"
 SRCREV  = "${AGL_APP_REVISION}"
 
-PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
 
-# build-time dependencies
-DEPENDS += "qtquickcontrols2 \
-            libqtappfw \
-            libhomescreen \
-"
-
 inherit qmake5 aglwgt
 
 RDEPENDS_${PN} += "agl-service-bluetooth-map libqtappfw"