Add agl-ivi-demo-platform-flutter image
[AGL/meta-agl-demo.git] / recipes-demo / mediaplayer / mediaplayer_git.bb
index 897099a..ff84ae8 100644 (file)
@@ -18,7 +18,9 @@ SRCREV  = "9c7c1d105faeb57a5b79578318c5731d252c5414"
 
 S  = "${WORKDIR}/git"
 
-inherit qmake5 pkgconfig
+inherit qmake5 pkgconfig agl-app
+
+AGL_APP_NAME = "Mediaplayer"
 
 do_install:append() {
     # Currently using default global client and CA certificates
@@ -33,6 +35,4 @@ do_install:append() {
     install -m 0644 ${WORKDIR}/mediaplayer.token ${D}${sysconfdir}/xdg/AGL/mediaplayer/
 }
 
-FILES:${PN} += "${datadir}/icons/"
-
 RDEPENDS:${PN} += "libqtappfw mpd"