Remove usage of AGL_APP_REVISION
[AGL/meta-agl-demo.git] / recipes-demo / mediaplayer / mediaplayer_git.bb
index 08990dc..fcab4a0 100644 (file)
@@ -6,19 +6,33 @@ SECTION     = "apps"
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
-SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/mediaplayer;protocol=https;branch=${AGL_BRANCH}"
-SRCREV  = "${AGL_APP_REVISION}"
+DEPENDS = "qtquickcontrols2 libqtappfw"
 
-PV = "1.0+git${SRCPV}"
-S  = "${WORKDIR}/git"
+PV = "2.0+git${SRCPV}"
 
-# build-time dependencies
-DEPENDS += "qtquickcontrols2 \
-            qtwebsockets \
-            libqtappfw \
-            libhomescreen \
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/mediaplayer;protocol=https;branch=${AGL_BRANCH} \
+           file://mediaplayer.conf \
+           file://mediaplayer.token \
 "
+SRCREV  = "5461945a951debb86430b4e8c94e5666e543ba22"
+
+S  = "${WORKDIR}/git"
+
+inherit qmake5
+
+do_install:append() {
+    # Currently using default global client and CA certificates
+    # for KUKSA.val SSL, installing app specific ones would go here.
+
+    # VIS authorization token file for KUKSA.val should ideally not
+    # be readable by other users, but currently that's not doable
+    # until a packaging/sandboxing/MAC scheme is (re)implemented or
+    # something like OAuth is plumbed in as an alternative.
+    install -d ${D}${sysconfdir}/xdg/AGL/mediaplayer
+    install -m 0644 ${WORKDIR}/mediaplayer.conf ${D}${sysconfdir}/xdg/AGL/
+    install -m 0644 ${WORKDIR}/mediaplayer.token ${D}${sysconfdir}/xdg/AGL/mediaplayer/
+}
 
-inherit qmake5 aglwgt
+FILES:${PN} += "${datadir}/icons/"
 
-RDEPENDS_${PN} += "agl-service-mediaplayer libqtappfw"
+RDEPENDS:${PN} += "libqtappfw mpd"