libqtappfw: update SRCREV
[AGL/meta-agl-demo.git] / recipes-demo / libqtappfw / libqtappfw_git.bb
index 3b99ef1..de737eb 100644 (file)
@@ -6,15 +6,30 @@ SECTION     = "libs"
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
-DEPENDS = "qtbase qtdeclarative glib-2.0 bluez-glib"
+DEPENDS = " \
+    qtbase \
+    qtbase-native \
+    qtdeclarative \
+    qtwebsockets \
+    glib-2.0 \
+    bluez-glib \
+    connman-glib \
+    libmpdclient \
+    protobuf-native \
+    grpc-native \
+    protobuf \
+    grpc \
+"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/libqtappfw;protocol=https;branch=${AGL_BRANCH}"
-SRCREV  = "0fee9bfb0f656b78f34c44542329760be2980892"
+SRCREV  = "c1f95b6c98db5e2fd6275ca03b3d96aab426b843"
 S       = "${WORKDIR}/git"
 
 # PV needs to be modified with SRCPV to work AUTOREV correctly
-PV = "2.0+git${SRCPV}"
+PV = "2.0.1+git${SRCPV}"
 
-inherit cmake_qt5 pkgconfig
+inherit meson pkgconfig
+
+RRECOMMENDS:${PN} += "bluez5 connman mpd"
 
 BBCLASSEXTEND = "nativesdk"