Update radio support in demo application
[AGL/meta-agl-demo.git] / recipes-demo / libqtappfw / libqtappfw_git.bb
index edf2af0..a1001ab 100644 (file)
@@ -6,15 +6,30 @@ SECTION     = "libs"
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
-DEPENDS = "qtbase qtdeclarative glib-2.0 bluez-glib"
+DEPENDS = " \
+    qtbase \
+    qtbase-native \
+    qtdeclarative \
+    qtwebsockets \
+    glib-2.0 \
+    bluez-glib \
+    connman-glib \
+    libmpdclient \
+    protobuf-native \
+    grpc-native \
+    protobuf \
+    grpc \
+"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/libqtappfw;protocol=https;branch=${AGL_BRANCH}"
-SRCREV  = "0fee9bfb0f656b78f34c44542329760be2980892"
-S       = "${WORKDIR}/git/"
+SRCREV  = "22ad8cbaad00d89361cbd92023dd20a807bcf5cb"
+S       = "${WORKDIR}/git"
 
 # PV needs to be modified with SRCPV to work AUTOREV correctly
 PV = "2.0+git${SRCPV}"
 
-inherit cmake_qt5
+inherit meson pkgconfig
+
+RRECOMMENDS:${PN} += "bluez5 connman mpd"
 
 BBCLASSEXTEND = "nativesdk"