Update radio support in demo application
[AGL/meta-agl-demo.git] / recipes-demo / libqtappfw / libqtappfw_git.bb
index cc36e71..89e3c4e 100644 (file)
@@ -6,15 +6,30 @@ SECTION     = "libs"
 LICENSE     = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
-DEPENDS = "qtbase qtdeclarative glib-2.0 bluez-glib connman-glib"
+DEPENDS = " \
+    qtbase \
+    qtbase-native \
+    qtdeclarative \
+    qtwebsockets \
+    glib-2.0 \
+    bluez-glib \
+    connman-glib \
+    libmpdclient \
+    protobuf-native \
+    grpc-native \
+    protobuf \
+    grpc \
+"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/libqtappfw;protocol=https;branch=${AGL_BRANCH}"
-SRCREV  = "5ef90db242ad29c9772f2237b477c58ef65545c7"
+SRCREV  = "9a7e2c5420cae0669c149d5dddbcd99a8fac0038"
 S       = "${WORKDIR}/git"
 
 # PV needs to be modified with SRCPV to work AUTOREV correctly
 PV = "2.0+git${SRCPV}"
 
-inherit cmake_qt5 pkgconfig
+inherit meson pkgconfig
+
+RRECOMMENDS:${PN} += "bluez5 connman mpd"
 
 BBCLASSEXTEND = "nativesdk"